scalper 1.2 and 2.0